MAXIMUS111111111
31.03.2022 15:36

Составьте программу генерирующую одномерный массив из элементов двумерного массива а(n,n),расположенных над главной диагональю

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
trisk
25.08.2020 15:44
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 const m = 100; var i,j,n: byte; arr1: array [1..m,1..m] of integer; arr2: array [1..m] of integer; begin write('Ко-во эл-ов квадратной матрицы: '); readln(n); for i:=1 to n do begin for j:=1 to n do begin arr1[i,j]:=random(50); write(arr1[i,j],' '); end; writeln; end; writeln('Полученный массив:'); for i:=1 to n do for j:=1 to n do if (j < n-i+1) then begin arr2[i]:=arr1[i,j]; write(arr2[i],' '); end; writeln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота