Написать программу проверяющую гипотезу сиракуза для всех чисел от n до m. значения n и m вводятся пользователем с клавиатуры. результатом работы программы является последовательность чисел заканчивающихся ( по гипотезе сиракуза) единицей.
begin readln(a, b); for i := a to b do begin n := i; write(n); while n <> 1 do begin if (n mod 2) = 0 then n := n div 2 else n := (3 * n + 1) div 2; write(' -> ', n); end; writeln;
end; end.
чесно передрано с некого сайта и доработано под задачу
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку