ElenaBkv
25.07.2021 14:45

10 класс напишите программу, которая сначала считывает натуральное число, а затем печатает значение наибольшей из цифр в его записи в системе счисления с основание 4. исходное число не превышает 10000. заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SuperFox9472
03.10.2020 15:48
Var i,k,m,a:integer; 
begin 
write('n: '); readln(a); m:=0; 
for i:=0 to 6 do begin k:=(a shr (2*i))and 3; if k>m then m:=k end; 
writeln('Max 4-ciffer is ', m); readln 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота