007София
23.03.2023 21:00

)составить программу вычисления функции ( sin(x), если x< =a; z= ( cos(x), если a=b.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
copekuti
03.10.2020 15:06

var

a, b, x, s, c, t:real;


begin


writeln('Введите a');

readln(a);

writeln('Введите b');

readln(b);

writeln('Введите x');

readln(x);


if x<=a then

begin

s:=sin(x);

writeln ('Синус равен ', s);

end

else

writeln ('Синус вычислить нельзя, так как равенство не равно ', x, '<=', a);


if (a<x) and (x<b) then

begin

c:=cos(x);

writeln ('Косинус равен ', c);

end

else

writeln ('Косинус вычислить нельзя, так как равенство не равно ', a, '<', x, '<', b);


if x>=b then

begin

t:=tan(x);

writeln ('Косинус равен ', t);

end

else

writeln ('Косинус вычислить нельзя, так как равенство не равно ', x, '>=', b);


end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота