d245129
16.10.2021 07:49

Составьте программу вычисления среднего арифметического элементов массива а, состоящего из n элементов (n задается в блоке констант, элементы массива вводятся случайно и берутся из диапазона от -50 до 50). паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
artyrik412002
03.10.2020 14:55
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=15;

 Var
 ar:array[1..n] of integer;
 i:integer;
 sr:real;
begin
 randomize;
 writeln('Аrray:');
 for i:=1 to n do
  begin
   ar[i]:=random(-50,50);
   write(ar[i]:4);
     sr:=sr+ar[i];
  end;
 writeln;
 sr:=sr/n;
 writeln('Sr=',sr);
end.

Пример работы программы:
Аrray:
 -17  -7  31  49 -49   7  -6  17  30  37  25 -30  23 -40   7
Sr=5.13333333333333
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота