Войти
Регистрация
Спроси ai-bota
azaliyazaynulinnf
01.02.2020 15:09
Синформатикой! нужно написать следующую программу: найдите сумму всех четных чисел от 1 до 200
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
люси97
10.02.2022 00:57
В одной из кодировок Unicode каждый символ кодируется 2 байтами. Найди размер следующего предложения в данной кодировке. Беги, сокройся от очей, Цитеры слабая царица!...
154Dance3
21.01.2020 14:45
На экран программист вывел следующую строку: for I:=1 to 10 do write (a[i] , );Выбери правильное утверждение: 1)элементы массива выводятся в строку 2)вывод массива с...
julia071201
27.12.2022 05:24
ВАРИАНТ 1 1. Робот находится в клетке, отмеченной знаком %. Изобразите результат исполнения следующего алгоритмі. . але узор вверх Вверх Влево закрасить закрасить вправо...
alyaagafonova
22.05.2020 11:03
Подскажите ! program z1; var a, b, c, d, f: real; var x: integer; begin a: = x div 1000; d: = x div 10; b: = (x div 100) mod 10; c: = ( x mod 100) div 10; f: = a+b+c+d;...
asvazy123
16.03.2020 01:19
1 Компьютерные сети и их классификация в бухгалтерии малого предприятия, состоящего из 5 сотрудников, необходимо обмениваться данными. Но на предприятии нет средств для...
dimanchik0108
24.03.2022 11:40
Составить программу выводящую двумерный массив, элементами которого являются 0, а на главной диагонали стоят 2. (pascal) решите !...
Сл2064
06.02.2022 22:24
Перечислите и опишите основные элементы рабочего стола....
Vakluver
22.06.2022 22:28
Выберите выражения, значения которых равны 2: 1) 203 div 101 2) 58 div 25 3) 405 div 15 4) 80 div 37...
Vrronika778
25.04.2022 12:02
1. Из каких частей состoит программа SketchUp? 2. Какие имеются инструменты в панели Рисование и каковы их функции? 3. Какая функция у инструмента Тяни/Толкай? 4. В чем...
Настя456456
10.02.2023 23:17
Вийміть чотири символи з центру рядка. слово МАНДАРИН. …...
Ответ:
Samiko280106
25.09.2020 08:15
Сумма всех четных чисел от 1 до 200 - это на самом деле сумма чисел
2+4+6+...+198+200.
1. Самый короткий вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
Writeln(Range(2,200,2).Sum)
end.
Результат:
10100
2. Более длинный и более "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var s:=0;
var i:=2;
while i<=200 do begin
s:=s+i;
i:=i+2
end;
Writeln(s)
end.
3. Совсем "тупой школьный" вариант (решение "в лоб")
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 200 do
if i mod 2 =0 then s:=s+i;
Writeln(s)
end.
4. Улучшенный "школьный" вариант
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
var
i,s:integer;
begin
s:=0;
for i:=1 to 100 do s:=s+2*i;
Writeln(s)
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота