Ilya2569
30.04.2020 15:41

Дан массив, состоящий из целых чисел. напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). входные данные сначала задано число n — количество элементов в массиве (1n10000). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Zaya191
25.08.2020 14:33
//PascalABC.NET 3.1 сборка 1200
begin
    var a := ReadArrInteger(ReadInteger());
    Println(a);
    
    var k := 0;
    for var i := Low(a) + 1 to High(a) do
        if a[i - 1] < a[i] then k += 1;
    
    writeln(k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота