agzamov03
09.06.2020 04:11

Подскажите как отобрать фамилии.напишите программу, которая заполняет с клавиатуры массив 3x5 фамилиями, именами и отчествами (фамилии размещаются в первой строке, имена — во второй, отчества — в третьей). определите, есть ли в списке однофамильцы и выведите на экран их имена и отчества.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aaablaeva
24.01.2022 04:22

num = int(input('Кол-во человек: '))

number = int(input('Какое число в считалке? '))

print('Значит, выбывает каждый', number, 'человек.')

mens_list = list(range(1, num + 1))

out = 0

for _ in range(num - 1):

   print('Текущий круг людей', mens_list)

   start_count = out % len(mens_list)

   out = (start_count + number - 1) % len(mens_list)

   print('Начало счёта с номера', mens_list[start_count])

   print('Выбывает человек под номером', mens_list[out])

   mens_list.remove(mens_list[out])

   print()

print('Остался человек под номером', mens_list)

0,0(0 оценок)
Ответ:
krivobokova45
30.08.2021 23:28

violator_songs = {

'World in My Eyes': 4.86,

'Sweetest Perfection': 4.43,

'Personal Jesus': 4.56,

'Halo': 4.90,

'Waiting for the Night': 6.07,

'Enjoy the Silence': 4.20,

'Policy of Truth': 4.76,

'Blue Dress': 4.29,

'Clean': 5.83

}

li = {}

qty = int(input('Сколько песен выбрать? '))

print()

count=1

while count!=qty+1:

   song=input("Введите название " + str(count) + " песни: ")

   if song not in violator_songs:

       print("Ошибка. Такой песни в плейлисте нет или вы")

   elif song in li:

       print("Ошибка. Вы уже выбрали эту песню")

   else:

       li[song]=violator_songs[song]

       count+=1

print('Общее время звучания песен:',round(sum(li.values()),2), "минут")

Объяснение:

вы слишком много лишних "телодвижений" в коде устраиваете, хотя видно, что с программированием знакомы, были какие то языки до этого?

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота