Karcat2306
18.02.2020 12:45

Составить программу с ветвящейся структурой, используя условный оператор if для квадратного уравнения вида ax2+bx+c=0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olyasmirnova3
03.10.2020 13:30
Var a,b,c,d:real;
begin
readln(a,b,c);
d:=sqr(b)-4*a*c;
if d<0 then writeln('Net kornei');
if d=0 then writeln('x=',-b/(2*a));
if d>0 then writeln('x1=', (-b-sqrt(d))/(2*a),' x2=',(-b+sqrt(d))/(2*a));
end.
0,0(0 оценок)
Ответ:
leka777166
03.10.2020 13:30
Var a,b,c,x,x1,x2:real;
begin
writeln('');
readln(a,b,c);
d:=b*b-4*a*c;
if d<0 then writeln('корней нет');
if d=0 then x:=-b/2/a;
if d>0 then;
begin;
x1=:(-b+sqrt(d))/2/a;
x2:=(-2-sqrt(d))/2/a;
writeln('x1=',x1:10:2);
writeln('x2=',x2:10:2);
end;
end
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота