Kokos5424
30.07.2021 01:21

С++ написать программу, которая проверяет, является ли квадратная матрица симметричной относительно главной диагонали. входные данные в первой строке записаны через пробел размер квадратной матрицы n (количество строк равно количеству столбцов) ( 1 ≤ n ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по n натуральных чисел, разделённых пробелами. выходные данные программа должна вывести слово 'yes', если матрица симметричная, и слово 'no', если матрица несимметричная.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arinka200000
15.09.2020 23:52
//Dev C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    int n;
    cin>>n;
    cout<<endl;
    int **ma;
    ma=(int **)malloc(sizeof(int*)*n);
    for (int i=0;i<n;i++){
  ma[i]=(int*)malloc(sizeof(int)*n);}
    for(int i=0;i<n;i++){
            for(int j=0;j<n;j++)
              cin>>ma[i][j];
            cout<<endl;}
     for(int i=0;i<n-1;i++)
             for(int j=i+1;j<n;j++)
                         if(ma[i][j]!=ma[j][i]){
                         cout<<"NO";
                         cin.get();
                         cin.get();
                         return 0;}
     cout<<"YES";
     cin.get();
     cin.get();
     return 0;
}

Пример ввода:
4

1
2
3
4

2
1
2
3

3
2
1
4

4
3
4
1

Пример вывода:
YES
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота