дима4455
19.08.2021 11:00

Написать программу для паскаль абц, но при не слишком сложных операций. "пусть n - натуральное число и пусть означает 1*3*5**n для нечетного n и 2*4**n для четного n. вычислить " - факториал. т.ею нужно ввести натурально число(например 5), а программа должна посчитать произведение нечетных чисел(1*3*5=15)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
милка328
15.09.2020 23:52
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var n,i: integer;
p:BigInteger;
begin
  p:=1;
  write('Введите N ');readln(n);
  if n mod 2<>0 then i:=1 else i:=2;
      while i<=n do begin
        p:=P*i;
        i:=i+2;
      end;
    writeln(p);
end.

Тест №1
Введите N 6
48

Тест №2
Введите N 5
15
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота