vasilchukanna1
25.02.2023 01:01

Вводятся два натуральных числа. напишите программу, которая делает то же самое, что и в примерах входных и выходных данных. будьте внимательны, числа и знаки операций разделены пробелами. sample input 1: 2 3 sample output 1: 2 + 3 = 5 sample input 2: 13 8 sample output 2: 13 + 8 = 21 , ! в с++!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Qwerty20020505
06.05.2022 08:43

#include <iostream>

#include <cmath>

#include <algorithm>


int main()

{

size_t

 N, M;

std::cin >> N >> M;

int** arr = new int*[N];

for(int i = 0; i < N; i++)

 arr[i] = new int [M];

 

for(int i = 0; i < N; i++)

 for(int j = 0; j < M; j++)

  std::cin >> arr[i][j];

size_t max(abs(arr[0][0]));

for(int i = 0; i < N; i++)

 std::for_each(arr[i], arr[i]+M, [&max](auto& var)

 {

  if(abs(var) > max)

   max = abs(var);

 });

std::cout << "Максимальный элемент по модулю: " << max << std::endl;

for(int i = 0; i < N; i++)

 delete[] arr[i];

delete[] arr;

}


Задана матрица размером n×m. найти максимальный по модулю элемент матрицы
0,0(0 оценок)
Ответ:
lopkin
22.12.2021 21:22
Содержание понятия — это совокупность существенных и отличительных признаков предмета, качества или множества однородных предметов, отражённых в этом понятии, поскольку с точки зрения логики всякое понятие имеет содержание и объём. например, содержанием понятия «коррупция» является совокупность двух существенных признаков: «сращение государственных структур со структурой преступного мира» и «подкуп и продажность общественных и политических деятелей, государственных чиновников и должностных лиц». о содержании понятия нельзя говорить в отрыве от его объёма. объёмом понятия называется множество обобщённых в нём предметов. например, под объёмом понятия «товар» подразумевается множество всех изделий, предлагаемых рынку как сейчас, так и в прошлом или в будущем. а чтоб понятнее: род - цветок, фрукт, овощ, буква, цифра, орудие, прибор, животное, насекомое, металл, орган, подросток, дом, день, военный, вид - школьник, лодка, олово, почки, морковь, микроскоп, два, фиалки, сержант, топор, груши, "у", тюлень, резиновая лодка, оса, деревянный дом, зимний день. кажется так. вот род цветок, а вид фиалка. или род овощ, а вид морковь. в род входит класс. цветок - фиалка фрукт - груши овощ - морковь буква - у цифра - 2 орудие - топор прибор - микроскоп животное - тюлень насекомое - оса
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота