ksussshhhaaa
19.07.2020 04:46

Составить программу паскаль, которая выводит на экран олимпийские кольца. , заранее большое )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ruma1974
03.10.2020 12:51
Uses crt,graph;
var
  gd, gm, xc, yc, r, x, y: integer;

begin
  clrscr;
  repeat
    writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
    readln(xc, yc);
  until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
 
  gd := 0;
  initgraph(gd, gm, '');
  setbkcolor(15);
  cleardevice;
 
  r := 50;
  setlinestyle(0, 0, 3);
  setcolor(9);
  circle(xc, yc, r);
  setcolor(8);{темно-серый, черный не нарисовать}
  circle(xc + 2 * r, yc, r);
  setcolor(12);
  circle(xc + 4 * r, yc, r);
  setcolor(14);
  circle(xc + r, yc + r, r);
  setcolor(10);
  circle(xc + 3 * r, yc + r, r);
  readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота