sxxaaa
29.03.2020 03:21

Составить программу нахождения количества положительных элементов в массиве из n вещественных чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Холзи14
24.09.2020 12:50
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var a:=ArrRandomReal(ReadInteger('n='),-20,20);
  a.Println;
  Writeln('Положительных: ',a.Where(x->x>0).Count)
end.

Тестовое решение:
n= 7
-17.1342332089014 3.03964398011549 16.2039925512876 -6.95437877762801 13.9224117034685 -1.08502876995366 11.8818603045688
Положительных: 4
0,0(0 оценок)
Ответ:
Albuss
24.09.2020 12:50
Const
  max = 20;

var
  arr : array [1..max] of real;
  count, i : integer;
begin
  for i := 1 to max do
    arr[i] := random(100) - 50;

  for i := 1 to max do
    write(arr[i], ' ');
  writeln();

  for i := 1 to max do
    if arr[i] > 0 then
       count := count + 1;

  writeln('Количество положительных чисел: ', count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота