Софія133
21.04.2021 04:19

Напишите программу по паскалю. дано трехзначное натуральное число a. требуется определить, какая из его цифр большая. исходные данные: 835. результат: 8.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
drart77
24.09.2020 11:38
Var a,c,k,max,chislo: integer;
begin
readln(chislo);
max:=-10;
c:=1;
repeat
a:=chislo div 10
c:=c+1;
until a=0;
k:=10;
for i to c do begin
if (chislo mod k)> max then max:=(chislo mod k)
chislo:=chislo mod k;
end;
writeln ( max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота