yasharks2013
28.03.2020 05:50

Напишите программу, , на pascal. даны координаты нижнего левого угла квадрата на плоскости x и y, и его площадь s. требуется проверить, попала ли точка, координаты которой задаёт пользователь, внутрь или на границу квадрата.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nemuverus
28.05.2020 07:17

uses crt;
var x,y,s,z1,z2,c1,c2:real;
begin
write('s=');
read(s);
write('x=');
read(x);
write('y=');
read(y);
s:=sqrt(s);
write('vvedite 1 koordinaty');
read(c1);
write('vvedite 2 koordinaty');
read(c2);
z1:=s+x;
z2:=s+y;
if (c1<=z1)and(c2<=z2)and(c1>=x)and(c2>=y) then
write('to4ka popala')
else
write('to4ka ne popala.');
read;
end.

 

где с1-первая координата, с2-вторая, z1 и z2-вс точки))) ну там разберешься)))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота