hshgahahah
14.04.2020 00:36

20 ! составить программу на языке с++: 1. описать структуру с именем tovar, которая содержит следующие поля: - name - название товара; - cost_z - цена закупки товара; - cost_p - цена продукции. - quantity -количество единиц товара; - pributok - прибыль. 2. написать программу, которая использует данную структуру и выполняет следующие действия: - вводит из текстового файла sklad.dat список книг, согласно структуры, и выводит его на экран, используя элемент список; - вычисляет прибыль по каждому товару; - добавляет в начало списка n новых товаров; - удаляет товар, который приносит прибыль; - с вновь списка записать в двоичный файл sklad.sol все товары, которые имеют наибольшую прибыль. 3. написать программу, которая считывает из двоичного файла sklad_n.dat, данные обо всех товарах и записывает в файл tovar.dat товар, цена которого превышает среднюю цену товара .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ririf
05.08.2021 21:54

( Решение на Pascal )

Не совсем ясно, каким образом составители задачи планировали найти среди случайных вещественных 10 чисел в диапазоне от -60 до 100 числа, кратные 8.

Но ради Бога:

var A: array [1..10] of real;

var i,s: integer;

begin

s:=0;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random()*160-60;

 write(A[i]:3:5,' ');

 if (A[i]>10) and (A[i]-trunc(A[i])=0)  

 and (trunc(A[i]) mod 8 =0) then

 s:=s+1;

 end;

writeln();

writeln('Количество элементов массива,',

'кратных числу 8 и больших 10: ',s);

end.


Дан одномерный массив A[10]. Элементы массива – это вещественные случайные числа большие -60 и меньш
0,0(0 оценок)
Ответ:
skseeen15
05.08.2021 21:54
Веб-дизайнер:Такой специалист занимается созданием сайтов и придумывает уникальные дизайнерские решения для них. Сегодня каждая уважающая себя фирма желает иметь свой Интернет-ресурс, а чтобы он был интересен для пользования, у него должна быть довольно удобная система навигации и интересное эстетическое оформление. Именно эти задачи и стоят перед веб-дизайнерами.

Вид деятельности «Программирование» - аналитик компьютерных систем, системотехник, инженер по автоматизированным системам, программист.
Вид деятельности «Обслуживание компьютерной техники» - IT-специалист (менеджер) , оператор ПК (ЭВМ) , системный интегратор, системный администратор, специалист по защите.
Вид деятельности «Искусство» - дизайнер, веб-дизайнер, фотограф, клипмейкер, фрилансер.
Вид деятельности «Полиграфия» - пейджмейкер, копирайтер, рерайтер, корректор, художественный и технический редактор, верстальщик, оператор компьютерного набора.
Вид деятельности «Офис, организация, предприятие» - секретарь, референт, делопроизводитель, машинистка, бухгалтер, менеджер, консультант.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота