gizut
04.03.2021 04:22

Написать программу которая создает одномерный массив из n случайных эллементов (др1000) и выводит на экран 1. сам массив 2. кол-во нечет чисел 3. наим. эллемент массива 4 ср. ариф. членов массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
сабина419
03.10.2020 11:32
Писал в среде PascalABC:

var a:array of integer;   
      k,min,s,n,i:integer;
begin
write('Задайте размер массива = ');readln(n);
writeln;
setlength(a,n);
for i:=0 to n -1 do begin
a[i]:=random(101);
if a[i] mod 2 <> 0 then k:=k+1;
if (a[i] < min) or (i=0) then min:=a[i];
s:=s+a[i];
end;
writeln('Массив:');
writeln(a);
writeln('Кол-во нечетных элементов = ',k);
writeln('Минимум = ',min);
writeln('Среднее ариф. = ',s/n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота