ян6
26.12.2020 04:25

Составить программу в паскале. найти количество положительных элементов массива х(3,3), заполненного с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
2005kolzaarina2
19.08.2020 15:56
Program foo;
var
b : array[1..3] of array[1..3] of integer;
c : integer;
i, j : byte;

begin
writeln('Заполните массив:');
for i := 1 to 3 do begin
writeln('Строка ', i);
for j := 1 to 3 do
readln(b[i][j]);
end;

c := 0;
for i:=1 to 3 do begin
for j:=1 to 3 do begin
write(b[i][j]:5, ' ');
if b[i][j] > 0 then inc(c, 1);
end;
writeln;
end;
writeln('Найдено ', c, ' положительных элементов');

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота