ЗайчонокЛаймик
21.05.2020 04:19

Составьте программу вычисления суммы тех элементов одномерного массива а(n), что расположены перед нулевым элементом данного массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NamaruC3
07.08.2020 12:52
В C++
#include <iostream>
using namespace std;

int main() {
    const int N = 10;
    int A[N] = {12, 14, 6, 8, 23, 0, 23, 4, 5, 7}; //заполняем как-нибудь массив
    int i;
    int sum = 0;
    for (i = 0; i < N; i++)
        if (A[i] != 0)
            sum = sum + A[i];
        else
            break;
    cout << "Sum: " << sum << endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота