SmolentsevaMasha
17.10.2020 04:22

Написать программу, которая считывает число с экрана и выводит сумму цифр этого числа. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zaharuch
23.09.2020 20:53
Var
  n, s: integer;

begin
  write('Число: ');
  readln(n);
  s := 0;
  while n > 0 do
  begin
    s := s + n mod 10;
    n := n div 10
  end;
  writeln('Сумма цифр = ', s);
end.

Тестовое решение:
Число: 12345
Сумма цифр = 15
0,0(0 оценок)
Ответ:
TumblrPrincess
23.09.2020 20:53
На Java
http://pastebin.com/SbfSZLFK

ввод - 1234567890123456
вывод - 66

var n, sum: integer;
begin
readln(n);
sum := 0;
while n > 0 do begin
sum := sum + n mod 10;
n := n div 10
end;
writeln(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота