Fan111111
28.11.2021 12:39

Написать программу с использованием цикла с постусловием рараметром и составит и блок схемы дано натуральное число определить количество его нечетеых делителей

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Program dividers;
var
    c,i,n :Integer;
begin
     readln(n);
     repeat
          if ( (n mod i) = 0 ) and ( (i mod 2) <> 0) then c:= c + 1;
          if  ( (n / i) mod 2) <> 0 then c:= c + 1;
          i:= i + 1;
     until i < (sqrt(n) + 1);
     writeln(c);
end.
   
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота