culi42
18.08.2022 19:38

1. измените программу из 2 таким образом, чтобы, при необходимости, можно отказаться от выполнения теста и корректно выйти из программы (используйте оператор while..do) 2. вычислить сумму натуральных четных чисел, не превышающих n. программу составьте двумя используя цикл с предусловием и цикл с постусловием.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:

а я разве их не решал

но ладнооо

1)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
Begin
clrscr;
readln(stroka);

i:=1;
repeat

val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;

until i=length(stroka);
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
if x=10 then writeln('TRUE')
else writeln('ELSE');
end.

2 я не знаю как решать

3)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
writeln(x);
end.

 4)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka)-1 do
for k:=1 to length(stroka)-i do if mas[k]=mas[k+1] then x:=x+1;
if x>0 then writeln('TRUE')
else writeln('FALSE');
end.

0,0(0 оценок)
Ответ:
ddfgdfgdfg
26.09.2020 06:20
Судя, по ключевым словам надо написать программу на языке Pascal с использованием цикла с потусловием. Алгоритм может быть такой:
1. Создадим массив для хранения информации о количестве встретившихся цифр во введенном числе.
2. Ввод самого числа, далее в цикле находим остаток от деления на 10 и увеличиваем значение элемента массива с индексом равным получившемуся остатку на 1. Делим число нацело на десять. Повторяем пока число не равно 0.
3. Выводим результат. В массиве индекс элемента указывает на цифру числа, а значение элемента на количество этой цифры в числе. 

//РасаlABC.net v3.1

var a:array[0..9]of integer;

n,i,m: integer;

begin

  readln(n);

  repeat

    m:=n mod 10;

    inc(a[m]);

    n:=n div 10;

  until n<=0;

  for i := 0 to 9 do begin

    if a[i]>1 then writeln('Цифра:',i,' количество:', a[i]);

  end;

end.

Тестовый прогон:

1112333

Цифра:1 количество:3

Цифра:3 количество:3

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота