EvilIncognito
24.11.2022 07:54

Составить программу вычисляющую сумму квадратов первых n натуральных чисел. количество чисел n задаётся во время работы программы. для разработки использовать приложение visual basic.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Оля142768
03.10.2020 11:03
1. Консольное приложение:

Module Module1

    Sub Main()
        Dim n, i, s As Integer
        Console.Write("Введите число N")
        n = Console.ReadLine
        s = 0
        For i = 1 To n
            s = s + i * i
        Next
        Console.Write(s)
        n = Val(Console.ReadLine)

    End Sub

End Module

2. Приложение Windows Forms:
На форме 3 объекта:
TextBox1 - для ввода N
Textbox2 - для вывода суммы квадратов
Button1 - чтобы запустить процесс вычислений

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim i, s As Integer
        s = 0
        For i = 1 To Val(TextBox1.Text)
            s = s + i * i
        Next
        TextBox2.Text = s
    End Sub
End Class
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота