feruza1111
20.11.2021 02:50

Напишите программу, которая вычисляет сумму всех отрицательных чисел от 1 до n. если можно побыстрее, а то на завтра нужно.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mam1975
03.10.2020 10:32
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  Writeln('s=',Range(ReadInteger('n='),-1).Sum)
end.

Тестовое решение:
n= -8
s=-36

"Школьный вариант"

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
var
  i,n,s:integer;
begin
  s:=0;
  Write('n='); Read(n);
  for i:=-1 downto n do s:=s+i;
  Writeln('s=',s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота