Superclassehdh
01.05.2023 12:56

Pascal 1. дан прямоугольный треугольник с катетами a и b. составьте программу для вычисления гипотенузы c, периметра, площади, радиуса вписанной и описанной окружности. напишите программу в pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Anif
31.07.2020 17:56
Program calculations;
var a,b,c, S, P,poluperimetr , Radius1, radius2: real;

begin
writeln ('Enter a:');
readln(a);
writeln('Enter b:');
readln(b);
c:=sqrt(a*a+b*b);
S:=(a*b)/2;
P:=a+b+c;;
poluperimetr:=P/2;
Radius1:=c/2;
radius2:=sqrt(((poluperimetr-a)*(poluperimetr-b)*(poluperimetr-c))/poluperimetr);
writeln('c=',c:2:2);
writeln('S=',S:2:2);
writeln('P=',P:2:2);
writeln('Radius1=',Radius1:2:2);
writeln('radius2=',radius2:2:2);
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота