Мирослава1509061
13.03.2021 10:51

Плачу много ! составьте программу для определения количества четных и нечетных цифр в записи данного натурального, пятизначного числа. (в обычном паскале)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
halseylove
23.09.2020 13:07
Var a,c,n : Longint;
Begin
  Readln(a);
  c:=0; n:=0;
  While a>0 do
  Begin
    If a mod 10 <> 0 then
      If Odd(a mod 10) then Inc(n) else Inc(c);
    a:=a div 10;
  end;
  Writeln('Чётных: ',c);
  Writeln('Нечётных: ',n);
end.
0,0(0 оценок)
Ответ:
anmon07
23.09.2020 13:07
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var n,x,n1,n2: integer;//n1-кол-во четных, n2-нечетных
begin
  readln(n);
  while n>0 do  begin
  x:=n mod 10;
  if x mod 2 = 0 then n1:=n1+1
    else n2:=n2+1;
  n:=n div 10;
  end;
  writeln('Четных: ',n1,'  Нечетных: ',n2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота