Анна26112004
15.11.2020 07:35

Составить программу для c++ "ввести возраст человека и вывести его вместе со словом год,года,лет(пример вам 1 год,вам 2 года,вам 55 лет)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arinapes30
03.10.2020 09:58
#include <iostream>
int main()
{
    using namespace std;
    system("chcp 1251 > nul"); //для кириллицы
    int age;
    cout << "Введите возраст: ";
    cin >> age;
    if (age > 4 && age < 21)
         cout << age << " ЛЕТ" << endl;
    else if (age % 10 == 1)
        cout << age << " ГОД" << endl;
    else if (age % 10 > 1 && age % 10 < 5)
        cout << age << " ГОДА" << endl;
    else
        cout << age << " ЛЕТ" << endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота