DixonVeit
05.06.2022 10:03

Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на паскале)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
stars28082003
15.09.2020 21:24
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
  a, s, n: integer;
begin
  while s < 1000 do
  begin
    if a mod 2 <> 0 then begin
      s := s + sqr(a);
      n := n + 1;
    end;
    a := a + 1;
  end;
  writeln(n-1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота