дэнчик626
27.09.2021 22:46

Нужна ! необходимо написать программу( в паскале) которая выведет двумерный массив рандомных чисел(3*3) на экран, а затем поменяет 1 и 3 строчку местами

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
eseniadautbekova
23.09.2020 10:57
Const n=3; 
var a:array[1..n,1..n] of integer;
i,j,k:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin for j:=1 to n do
  begin
  a[i,j]:=random(50)+50;
  write(a[i,j]:4);
  end;
  writeln;
 end;
for j:=1 to n do
 begin k:=a[1,j]; a[1,j]:=a[3,j]; a[3,j]:=k; end;
writeln('Измененный массив');
for i:=1 to n do
 begin
 for j:=1 to n do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  71  82  65
  87  98  79
  50  74  84
Измененный массив
  50  74  84
  87  98  79
  71  82  65
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота