Вика12342001
23.05.2020 21:16

1) напишите программу которое вводит натуральное число"n" и находит сумму всех натуральных чисел от 1 до n (цикл пока). 2)напишите программу которое вводит натуральное число "n" и выводит первые "n" четных натуральных чисел. 3)напишите программу которая вводит натуральные числа "a и b" и выводит квадраты натуральных чисел в диапазоне от "a до b". , а то не

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kuzhbapolina20
25.08.2020 11:52

1)

var

   a, n, s: integer;

begin

   write('n = ');

   Readln(n);

   

   a := 1;

   while a <= n do

   begin

       s := s + a;

       a := a + 1;

   end;

   writeln(s);

end.

2)

var

   a, n: integer;

begin

   write('n = ');

   Readln(n);

   a := 1;

   while a <= n do

   begin

       writeln(2 * a);

       a := a + 1;

   end;

end.

3)

var

   a, b: integer;

begin

   write('Введите числа a и b: ');

   Readln(a, b);

   

   while a <= b do

   begin

       writeln(a, '^2 = ', sqr(a));

       a := a + 1;

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота