Avry99
27.12.2022 06:55

Все сделать в паскале. дан массив из 12 элементов, в котором есть положительные и отрицательные чи сла (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. составьте программу, в которой 1 вариант: все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. вывести на экран исходный и полученный массив как в классе; дополнительная оценка, если появляется дополнительная возможность ввода своих чисел с клавиатуры с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zigzag19
03.10.2020 09:29
Program mm;
var a:array[1..12] of integer;
begin
for i:=1 to 12 do begin
а[1]:=5;
 а[2]:=4;
 а[3]:=-3;
 а[4]:=1;
 а[5]:=0;
а[6]:=-4;
 а[7]:=(у тебя не написано);
 а[8]=25;
 а[9]=-8;
 a[10]=-5;
 а[11]=-17;
 а[12]=-1;
end;
writeln('Вот исходный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
for i:=1 to 12 do begin
if (A[i]<0) then a[i]:=1;
if (a[i]>0) then a[i]:=-5;
end;
writeln('Вот полученный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
writeln(' Введите 12 чисел');
for i:=1 to 12 do readln(A[i]);          (это доп оценка)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота