cawa0273
20.02.2021 02:03

Напишите программу, которая получает натуральные числа a и b(a меньше b) и выводит все простые числа в интервале от a до b

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kaytha
31.07.2020 17:21
PascalABC.NET 3.4.2, сборка 1933 от 01.04.2019

begin

 var (a, b) := ReadInteger2;  // Считывание a и b

 var simple := ArrFill(b + 1, true);  // Инициализация булевого массива значением true.

// Реализация решета Ератосфена

 for var i := 2 to b do

   if simple[i] then  

   begin

     var j := i * i;

     while (j <= b) do

     begin

       simple[j] := false;

       j += i;

     end;

   end;


 // Вывод на экран найденного результата

 for var i := a to b do

   if (simple[i]) and (i > 1) then i.Print

end.

0,0(0 оценок)
Ответ:
fonvg
31.07.2020 17:21

var a,b,i,d,k:integer;

begin

write ('Введите натуральные числа a и b (a<b): ');

readln (a,b);

write ('Простые числа от ',a,' до ',b,': ');

for i:=a to b do

begin

for d:=2 to i do

if i mod d = 0 then k:=k+1;

if k=1 then write(i,'  ');

k:=0

end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота