dashapendus2003
23.09.2022 01:29

Написать программу: вычислить количество точек с целочисленными координатами, в круг с радиусом r и с центром в начале координаты ур: x*x+y*y= r*r

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kindgirl999
22.09.2020 23:47
Var i,j,n,k: integer;    r: real;begin  write('радиус:  ');  readln(r);  n:=trunc(r);  k:=0;  for i:=-n to n do  for j:=-n to n do  if sqr(i)+sqr(j)<=sqr(r) then k:=k+1;  writeln('число точек в круге:  ',k);end.    
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота