tanyaxxx15
11.01.2023 11:15

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот период. прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0). на входе программа получает период n

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
20112005505438
27.05.2020 23:54

через генератор случайных чисел
program noname;
uses crt;
var
n,k,i:integer;
a:array[1..1000] of longint;
max:longint;
begin
clrscr;
write('vvedi period n=');
readln(n); k:=0;
for i:=1 to n do begin
randomize;
a[i]:=random(10000);
writeln(a[i]);
if a[i]-1000<0 then k:=k+1;
end;
max:=a[1];
for i:=2 to n do
if max<a[i] then max:=a[i];
writeln(k,'-дни без прибыли ',max,'-максимальная выручка');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота