dimon007228
23.02.2023 14:55

Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элементов которой максимальна, и поменять местами эту строку и последнюю строку матрицы. если данная строка оказалась последней, выдать на экран сообщение, о том, что менять строки местами не нужно.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Hujaev01
27.05.2020 22:27

На входе вводим с клавиатуры размерность массива: n строк и m столбцов.

Первые два вложенных цикла - это ввод двумерного массива с датчика случайных чисел randomize.

Далее во вложенных циклах ищем максимальную сумму элементов по строкам и запоминаем номер строки в переменную k.

Строку с выводом s и k писать не нужно.

Далее один цикл обмена к-той строки и последней.

Последние вложенные циклы выводят изменённый массив.

Прежде чем выводить массив нужно поставить поверку:

If k=m then write(‘Менять строки местами не нужно’) else begin и последние два вложенных цикла.


Написать программу на ! дана прямоугольная матрица размером . определить номер строки, сумма элемент
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота