polina033
12.04.2020 18:17

Составить программу для нахождения количества таких трехзначных чисел фибоначчи, которые делятся на сумму своих цифр нацело. программа - pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
VarvaraErrorFell
03.10.2020 08:41
Var
 a,b,k,s: integer;
begin
 k := 0;
 a := 1;
 b := 1;
 while b < 1000 do
   begin
   if b >= 100 then
     begin
     s := b div 100 + b div 10 mod 10 + b mod 10;
     if b mod s = 0 then
       k := k + 1
     end;
   b := a + b;
   a := b - a;
   end;
 write(k)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота