Calleron
05.11.2021 07:21

Написать программу на паскале дана строка текста напечатать все слова,заканчивающиеся на "ов". если можно,то напишите программу с функции pos

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Asig
03.10.2020 08:41
Считается, что слова отделяются друг от друга пробелом.
var s:string; p:integer;
begin
writeln('Введите строку:');
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
 begin
 if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));
 delete(s,1,p);
 p:=pos(' ',s);
 end;
end.

Пример:
Введите строку:
пример кров слово шов олово ров
кров
шов
ров
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота