NicholasM
09.04.2022 05:05

Составить программу для нахождения произведение чисел от 1 до n. для циклов: 1)for 2)while 3)until

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vikapinigina
22.09.2020 18:47
//Pascal
var
  a, p:  word;
  i, n: integer;

begin
  readln(n);
  //цикл for
  p := 1;
  for i := 1 to n do
    p := p * i;
  writeln(p);
 
  //цикл while
  i := 1;
  p := 1;
  while i <= n do
  begin
    p := p * i;
    i := i + 1;
  end;
  writeln(p);
 
  //цикл repeat
  i := 1;
  p := 1;
  repeat
    p := p * i;
    i := i + 1;
  until i > n;
  writeln(p);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота