Chocolateteapot0507
11.11.2021 00:12

Впаскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ксения222332
22.09.2020 18:35
Const N = 3;
var a: array[1..N] of integer;
i, x: integer;
begin
x:=0;
for i:=1 to N do begin
read(a[i]);
if a[i] mod 2 = 0 then
x:=x+1;
end;
if 2*x >= N then
for i:=1 to N do begin
a[i]:=a[i]*2;
writeln(a[i]);
end
else
for i:=1 to N do begin
a[i]:=a[i]+1;
writeln(a[i]);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота