Трамбовщик
20.05.2021 19:22

Дано некоторое число составьте программу которая выводит какое это число положительное или отрицательное если оно положительное уменьшить в 2 раза а в другом случае взвести в квадрат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Pollyyyyyyyyyyyyyyy
03.10.2020 08:06
//Pascal ABC.NET v3.1 сборка 1172

Var
 a:real;
begin
 readln(a);
 if a>0 then writeln('Положительное, ',a/2) else
  if a<0 then writeln('Отрицательное, ',sqr(a)) else
   writeln('0');
end.

Пример ввода:
-12
Пример вывода:
-, 144
0,0(0 оценок)
Ответ:
darya2401
03.10.2020 08:06
По моему такая задача уже несколько раз была здесь.
//Pascal
var a:integer;
begin
  readln(a);
  if a>0 then writeln('Положительное ', a/2)
     else
         if a<0 then writeln('Отрицательное', a*a);
  if a=0 then writeln('0 - не положительное и не отрицательное число');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота