Фыффыф
08.01.2020 11:13

Нужно написать программу на языке паскаль, которая будет убирать из строки все символы кроме цифр. пример: входной- a3f4h5k& 2 выходной: 3452

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dobryninatonya
15.09.2020 19:17
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString;
  s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
  Writeln(s)
end.

Тестовое решение:
a3f4h5k&2
3452
0,0(0 оценок)
Ответ:
Awzida
15.09.2020 19:17
Var s:string;
l,i:longint;
begin
read(s);
l:=length(s);
for i:=1 to l do
if (s[i]>='0')and(s[i]<='9') then write(s[i]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота