Отличник1029
21.09.2020 03:09

Вpascal написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
viktoria2206
30.08.2020 20:15
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString('Введите двухзначное 16-ричное число');
  var mH:array['A'..'F'] of integer:=(10,11,12,13,14,15);
  if s.Length=1 then s:='0'+s;
  var c:=s.ToCharArray;
  var n:=0;
  for var i:=0 to 1 do
    case c[i] of
    '0'..'9':n:=16*n+StrToInt(c[i]);
    'A'..'F':n:=16*n+mH[c[i]];
    else begin
      Writeln('Недопустимый символ: ',c[i]);
      Exit
      end
    end;
  Writeln('Десятичный эквивалент: ',n)
end.

Тестовое решение:
Введите двухзначное 16-ричное число 3A
Десятичный эквивалент: 58
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота