На паскале написать программу сокращения дроби , где n – целое, m – натуральное число. использовать алгоритм евклида. разработать тесты для проверки правильности работы программы.
Var n,m:integer; a,b:integer; begin read(n,m); a := abs(n); b := m; while a <> b do if a > b then a := a - b else b := b - a; b := m div a; a := n div a; writeln(a,'/',b); if a*m = b*n then writeln('Correct') end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку