Разработать схему алгоритма и написать программу a) вычисления среднего арифметического четырех чисел; b) вывода вашего роста , возраста и веса на экран4 c) вычисление значения корней квадратного уравнения выполнить трассировку программ.
1. var a, b, c, d: integer; sr: real; begin readln(a, b, c, d); sr := (a+b+c+d)/4; writeln(sr); end.
2. begin writeln('Рост: 181'); writeln('Вес: 81'); writeln('Возраст: 28'); end.
3. var a, b, c, d: integer; x1, x2: real; begin readln(a, b, c); d := b*b-4*a*c; if d > 0 then begin x1:=(-b+sqrt(d))/(2*a); x2:=(-b-sqrt(d))/(2*a); writeln(x1, ' ', x2); end; if d < 0 then begin x1:=-b/(2*a); writeln(x1); end; if d > 0 then writeln('Корней нет'); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку