умница603
22.04.2022 09:51

Составить программу поиска первых n чисел, равных сумме кубов своих цифр. программа - паскаль аbc

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
misarevakin6
07.09.2020 15:28
Var
n, i, s, x: integer;
begin
readln(n); //вводим n
for i:=1 to n do //проверяем каждое число от 1 до n
begin
s:=0; x:=i;
while x > 0 do //находим сумму кубов цифр
begin
s:=s + (x mod 10) * (x mod 10) * (x mod 10);
x:=x div 10;
end;
if s = i then //если сумма кубов равна i выводим i
writeln(i);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота