Вмассиве хранится информация о среднесуточной температуре за текущую неделю. составить программу, определяющую среднюю температуру за неделю и количество дней, в течение которых температура была выше средней
Var a: array[1..7] of integer; i, k: integer; s: real; begin for i:=1 to 7 do begin write('Введите погоду для ', i, ' дня недели: '); readln(a[i]); s:=s+a[i] end; s := s/7; k:=0; for i:=1 to 7 do if a[i] > s then inc(k); writeln('Средняя температура: ', s); writeln('Кол-во дней: ', k); end.
Var ar:array[1..n] of integer; //массив дней i,k:integer; sr:real; begin k:=0; //счётчик превысивших for i:=1 to n do begin readln(ar[i]); //вводим дни sr:=sr+ar[i]; //заодно вычисляем сумму дневных температур end; sr:=sr/n; {делим сумму на количество дней, получаем среднюю температуру} for i:=1 to n do if sr<ar[i] then inc(k); {если температура некотрого для выше средней, увеличиваем счётчик} writeln('Средняя температура=',sr,', за неделю ', k,' дней превысили эту температуру'); end.
Пример ввода: 1 2 ... 7 Пример вывода: Средняя температура=4, за неделю 3 дней превысили эту температуру
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку