Nurana15
24.11.2021 01:54

Написать программу на паскале переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). входные данные вводится натуральное число, записанное в двоичной системе. выходные данные выведите число, записанное в десятичной системе. примеры входные данные 1 выходные данные 1 входные данные 1001 выходные данные 9

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
dbva
31.07.2020 15:16
{by Puporev}
const digit : string[16] = '0123456789ABCDEF';

Function ToDec(n:string;r:byte) : longint;
var m,i:longint;
begin
  m:=0;
  for i:=1 to length(n) do
  m:=m*r+pos(n[i],digit)-1;
  ToDec:=m;
end;
Var S : String;
Begin
  Readln(S);
  Writeln(ToDec(S,2));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота