lboik
24.11.2020 21:37

Написать программу, сокращающую обыкновенные дроби. числитель и знаменатель вводятся с клавиатуры. в программе использовать цикл с постусловием. пример. вводятся числа: 10 15 результат: 2 / 3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Pelyovin1980
27.05.2020 18:14

var i,x,y:integer;
b:boolean;
begin
readln(x,y);
for i:=2 to x do
if (x div i=x/i) and (y div i=y/i) then begin
x:=x div i;
y:=y div i;
end;
writeln(x,' ',y);
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота