komaman
28.06.2021 21:23

35 написать программу на языке программирования в паскале: найти все целые числа из промежутка от 100 до 300, у которых сумма делителей равна k? (k вводится с клавиатуры)​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
katyasvk
27.05.2020 18:08

var i,k,j,s:integer;

begin

  readln(k);

  FOR I:=100 TO 300 DO

  begin

     s:=0;

     for j:=1 to i do

     if i mod j=0 then s:=s+j;

     if s=k then writeln(i);

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота